Thanks for choosing Wahoo!

What devices are compatible with the RFLKT+?

The RFLKT+ pairs via Bluetooth 4.0, so you must have an iPhone 4s or newer, an iPad 3 or newer, the iPad mini, or the iPod Touch 5th Gen. Android compatibility varies, and also requires devices to have Bluetooth 4.0, check here for more information.   

Contact Support

Submit a ticket now

Phone Support

1(877) 978-1112

(M - F) 10am - 7pm EDT

UK: +44 800 808 5773

(M - F) 3pm - 12am BST

Chat Support

Open a chat session

(M - F) 10am - 7pm EDT

Powered by Zendesk