Thanks for choosing Wahoo!

What Android devices are compatible with the ELEMNT Bolt?

Android System Requirements:

  1. A device with a Bluetooth 4.0 (Smart) radio
  2. An Android device running version 4.4 KitKat or newer that allows Third Party App Access to the Bluetooth 4.0 (Smart) Radio

Compatible Devices:

Most Android devices running Android 4.4 KitKat or newer and with Bluetooth 4.0 will work. However, Wahoo Fitness has not tested complete compatibility with all devices. Please download the Companion App from the Google Play Store to ensure that it installs on your device before purchasing a product.

Contact Support

CALL US

1(877) 978-1112
(M-F) 10am-7pm ET UK?

UK: +44 800 808 5773
(M-F) 3pm-12am GMT US?